1. Home
  2. Tutorials
  3. CredSSP issue on my templates

CredSSP issue on my templates

Microsoft did in May 2018 release some updates to almost all Windows versions, like Windows 10, Server 2012 R2 and Server 2016. If you don’t update your Windows client used as a Remote Desktop device or update your servers with the 2018-05 Cumulative updates – you can’t connect to your RDP device.

If you get this message when using my templates – you have to fix the CredSSP issue on your client. You can follow this guide here…

Or just put the following text in Notepad, save it as a .reg file, and run it.

rdp_insecure_on.reg

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System\CredSSP]

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System\CredSSP\Parameters]
@=""
"AllowEncryptionOracle"=dword:00000002

rdp_insecure_off.reg (If you want to run the recommended settings from MS)

Windows Registry Editor Version 5.00

[-HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System\CredSSP]

[-HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System\CredSSP\Parameters]

After you get access to my templates again, please update them with the 2018-05 Cumulative updates from Microsoft.

Updated on July 19, 2018

Related Articles

Add A Comment

This site uses Akismet to reduce spam. Learn how your comment data is processed.